DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Supprime du contexte AWP une variable ajoutée par la fonction DéclareContexteAWP.
Remarque : Ne fonctionne que lors de la gestion des contextes sur disque (fonction ConfigureContexteAWP).
Exemple
GLOBAL
gsMaGlobale est une chaîne
 
SI DéclareContexteAWP(gsMaGlobale) = Faux ALORS
// Initialisation avec la valeur par défaut
gsMaGlobale = ValeurInitiale()
FIN
...
 
// En cas d'erreur supprime la valeur
SI bErreur = Vrai ALORS
AnnuleContexteAWP(gsMaGlobale)
FIN
Syntaxe
AnnuleContexteAWP([<Nom de la variable 1> [... [, <Nom de la variable N>]]])
<Nom de la variable 1> : Type de la variable (paramètre optionnel)
Nom de la première variable à supprimer du contexte.
<Nom de la variable N> : Type de la variable (paramètre optionnel)
Nom de la Nème variable à supprimer du contexte.
Remarques
  • Si la variable n'existe pas, aucune erreur n'est renvoyée.
  • Si aucune variable n'est indiquée, la session complète est annulée : toutes les variables mémorisées sont perdues, et le fichier de session est détruit. Pour recommencer à manipuler une session, il est nécessaire d'utiliser la fonction ConfigureContexteAWP.
  • Si votre projet utilise les sessions prélancées, cette fonction ne doit pas être utilisée dans l'événement "Initialisation" du projet. Cette fonction doit être utilisée dans l'événement "Initialisation du projet après connexion au site".
Composante : wd280page.dll
Version minimum requise
  • Version 12
Commentaires
Exemplo Looper manual no awp
https://windevdesenvolvimento.blogspot.com/2021/06/dicas-3355-windev-webdev-mobile-fazer.html
https://youtu.be/e8yvn_5syGQ
//Exemplo Looper manual no awp
// no projeto global // Initializing awp_Exemplo
ConfigureAWPContext(ctxDisk)
//na pagina looper co awp , no codigo da procedure pagina
garrMeu_looper_array is array of string
DeclareAWPContext(garrMeu_looper_array)
// initializing of btn looper (server)
LOOP_exemplo.DeleteAll()
FOR EACH sLinha OF garrMeu_looper_array
LOOP_exemplo.AddLine(sLinha)
END
// no click do btn looper server - ajax ativado
texto is string="Texto: "+TimeSys()
LOOP_exemplo.AddLine(texto)
ArrayAdd(garrMeu_looper_array,texto)
// botao fechar
CancelAWPContext(garrMeu_looper_array)
PageDisplay(PAGE_looper_com_sessao)

amarildo
15 juin 2021