PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple : Synchroniser des réplica en utilisant une procédure de filtre
HSynchroniseRéplica (Exemple)
Exemple : Synchroniser des réplica en utilisant une procédure de filtre
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)AjaxHFSQLHyper File 5.5 L'exemple suivant utilise une procédure WLangage lors de la réplication. Cette procédure FiltreRéplica permet de filtrer les enregistrements à prendre en compte lors de la réplication, mais aussi de gérer les conflits lors de la réplication.
SI HSynchroniseRéplica("C:\Données", "D:\Temp", rplVersAbonné, FiltreRéplica) = Vrai ALORS
Info("Réplication effectuée")
FIN
PROCÉDURE FiltreRéplica()
Jauge(RPL.NumOperation, RPL.MaxOperation)
// ******************************** Filtrage des enregistrements ********************************
// Exemple : Exportation du catalogue des produits en promotion
SI RPL.Sens = rplVersAbonné ET RPL.Opération = rplHAjoute ALORS
 SI RPL.Fichier = "Produit" ET {RPL.AliasSource + ".PROMO"} = Faux ALORS
  // L'enregistrement ne doit pas être copié
  RENVOYER Faux
FIN
FIN
// ************************************** Gestion des conflits ***********************************
// Exemple : Test si le produit existe déjà
// HLitRecherche(PRODUIT, CodeProduit, {RPL.AliasSource + ".CodeProduit"})
// SI HTrouve() ALORS
// // L'enregistrement ne doit pas être copié
// RENVOYER Faux
// FIN
// Pas de problème détecté
RENVOYER Vrai
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire