PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple : Création de plusieurs filtres et activation d'un filtre après l'autre
HDésactiveFiltre (Exemple)
Exemple : Création de plusieurs filtres et activation d'un filtre après l'autre
Deux filtres sont créés : un filtre sur l'âge du client et un filtre sur le code postal du client. Les filtres sont activés et désactivés selon les traitements réalisés.
// Définition des différents filtres
HFiltre(Client, AGE_Client, 50, 75)
HFiltre(Client, CodePostal, 34000, 34000)
 
// Active le filtre sur l'âge
HActiveFiltre(Client, AGE_Client)
HLitPremier(Client, AGE_Client)
TANTQUE HEnDehors() = Faux
// Procédure permettant d'envoyer un fax standard aux clients
EnvoieFax(50, 75)
HLitSuivant(Client, AGE_Client)
FIN
 
// Désactive le filtre sur l'âge
HDésactiveFiltre(Client, AGE_Client)
 
// Active le filtre sur le code postal
HActiveFiltre(Client, CodePostal)
 
HLitPremier(Client, CodePostal)
TANTQUE HEnDehors() = Faux
EnvoieFaxCP(CodePostal)
HLitSuivant(Client, CodePostal)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire