PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple : Union de vues
HFusionneVue (Exemple)
Exemple : Union de vues
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)AjaxHFSQLHFSQL Client/ServeurHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs) Deux vues sont créées pour sélectionner les joueurs de deux clubs différents. Ces deux vues sont fusionnées dans une vue finale qui est ensuite parcourue.
EXTERNE MaVue1, MaVue2, MaVue_Finale
// Création de la vue "MaVue1"
SI HCréeVue("MaVue1", Club_Montpellier, "Nom_Joueur", ...
"", "Nom_Joueur >" + Variable1 + "'", hVueDéfaut) = Faux ALORS
Erreur(HErreurInfo())
FIN
 
// Création de la vue "MaVue2"
SI HCréeVue("MaVue2", Club_Arles, "Nom_Joueur", "", ...
"Nom_Joueur >" + Variable2 + "'", hVueDéfaut) = Faux ALORS
Erreur(HErreurInfo())
FIN
 
// Fusion des deux vues dans la vue "MaVue_Finale"
SI HFusionneVue("MaVue_Finale", "MaVue1", "MaVue2", ...
hVueUnion, "Nom_Joueur", "Nom_Joueur") = Faux ALORS
Erreur(HErreurInfo())
FIN
 
// Parcours de la vue
HLitPremier("MaVue_Finale")
TANTQUE HEnDehors() = Faux
// Traitement à effectuer
HLitSuivant("MaVue_Finale")
FIN
 
// Destruction des vues
HDétruitVue(MaVue1)
HDétruitVue(MaVue2)
HDétruitVue(MaVue_Finale)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire