PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple : Ajout d'un fichier dans un mémo binaire
  • Exemple : Ajout d'une image dans un mémo
HAttacheMémo (Exemple)
Exemple : Ajout d'un fichier dans un mémo binaire
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)PHPAjaxHFSQLHFSQL Client/ServeurProcédures stockéesHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs)
L'exemple suivant permet d'ajouter un fichier quelconque dans une rubrique de type "mémo binaire" d'un fichier de données.
// Renseignement des différentes rubriques du fichier ...
 
// Un nom de fichier a été indiqué pour la description du produit ?
SI PAS SAI_NOM_FICHIER ~= "" ALORS
// Oui, on vérifie que ce fichier existe bien
SI fFichierExiste(SAI_NOM_FICHIER) = Faux ALORS
Erreur("Impossible d'ajouter " + ...
"le fichier de description du produit " + ...
"dans la base : ", HErreurInfo())
RETOUR // ou RENVOYER Faux
FIN
 
// Ajout du fichier qui contient la description du produit
// dans la rubrique mémo binaire de l'enregistrement
SI HAttacheMémo(PRODUIT, DESCRIPTIONPRODUIT, SAI_NOM_FICHIER, ...
hMémoBin, "Description du fichier") = Faux ALORS
Erreur("Impossible d'ajouter " + ...
"le fichier de description du produit " + ...
"dans la base : ", HErreurInfo())
RETOUR //ou RENVOYER Faux
FIN
FIN
 
// Ajoute (ou modifie) le produit au fichier des produits
SI HAjoute(PRODUIT) = Faux ALORS // ou SI HModifie(PRODUIT) = Faux ALORS
Erreur("Impossible de mettre à jour le fichier produit :", ...
HErreurInfo())
RETOUR //ou RENVOYER Faux
FIN
 
RENVOYER Vrai
Exemple : Ajout d'une image dans un mémo
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)PHPAjaxHFSQLHFSQL Client/ServeurProcédures stockéesHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs)
L'exemple suivant est une procédure permettant d'ajouter un produit dans le fichier de données PRODUIT. Pour chaque produit, cette procédure permet d'attacher l'image du produit dans le mémo de l'enregistrement.
// Procédure d'ajout d'un produit
FONCTION bAjouteProduit(sNomProduit, sImage)
 
// Nom du produit
PRODUIT.NOM = sNomProduit
 
// Photo du produit
SI HAttacheMémo(PRODUIT,PHOTO, sImage, hMémoImg) = Faux ALORS
RENVOYER Faux
FIN
 
// Ajoute le produit au fichier des produits
SI HAjoute(PRODUIT) = Faux ALORS
RENVOYER Faux
FIN
 
RENVOYER Vrai
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire