DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
HDésactiveFiltreAuto (Fonction)
En anglais : HDeactivateAutoFilter
Connecteurs Natifs (Accès Natifs)Disponible uniquement avec ce type de connexion
Désactive un filtre automatique sur les fichiers de données reliés lors du parcours d'un fichier XML. Ce filtre a été activé grâce à la fonction HActiveFiltreAuto.
Attention : Cette fonction est disponible uniquement pour l'Accès Natif XML.
Exemple
// Activation de tous les filtres auto possibles du fichier de données Client
HActiveFiltreAuto(Client, "*")
// sauf entre Client et Commande
HDésactiveFiltreAuto(Client, Commande)
 
/////////////////////////////
 
// Parcours des commandes
HLitPremier(Commande, IDCommande)
TANTQUE HEnDehors() = Faux
// Parcours les lignes de commande de la commande en cours
HLitPremier(LigneCde, IDCommande)
TANTQUE HEnDehors() = Faux
HLitSuivant(LigneCde, IDCommande)
FIN
// Commande suivante
HLitSuivant(Commande, IDCommande)
FIN
Syntaxe
<Résultat> = HDésactiveFiltreAuto(<Fichier de données de parcours> , <Fichier de données à ne pas filtrer>)
<Résultat> : Booléen
  • Vrai si le filtre est désactivé,
  • Faux en cas d'erreur (fichier de données ou rubrique inexistant).
<Fichier de données de parcours> : Chaîne de caractères
  • Nom du fichier de données utilisé pour le parcours.
  • "*" pour désactiver tous les filtres automatiques possibles.
Si les paramètres <Fichier de données de parcours> et <Fichier de données à ne pas filtrer> correspondent à "*", <Résultat> vaut Vrai et aucun filtre n'est désactivé.
<Fichier de données à ne pas filtrer> : Chaîne de caractères
  • Nom du fichier de données à ne pas filtrer lors d'un positionnement dans le fichier de données de parcours.
  • "*" pour désactiver tous les filtres automatiques possibles.
Si les paramètres <Fichier de données de parcours> et <Fichier de données à ne pas filtrer> correspondent à "*", <Résultat> vaut Vrai et aucun filtre n'est désactivé.
Composante : wd280hf.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire